KAAN Trib@ank und ALFBanCo3

Bei Problemen / Fragen zu Chipkarten oder Kartenlesern sind Sie hier richtig

KAAN Trib@ank und ALFBanCo3

Beitragvon Don » Sa 31. Jan 2009, 12:17

Hallo,

ich hatte bis vor kurzem noch die Version 2 von ALFBanCo verwendet. Da ich auf der Suche nach einem Kartenleser war, kam mir dann das Angebot auf die neuste Version upzudaten und einen Kartenleser zu erhalten gerade recht. Leider erkennt ALFBanCo nicht, dass der Leser eine eigene Tastatur hat - was natürlich aus meiner Sicht absolut unverständlich ist, wenn man beide Produkte in einem Paket anbietet...

Ihre Empfehlung aus der FAQ in den Optionen die PIN-Eingabe über Kartenleser-Tastatur einmal aus und wieder einzuschalten hat leider auch nicht geholfen. Setze ich beim Erkennen des Kartenleser die sichere PIN-Eingabe manuell, kann ich danach leider nicht mehr auf die Karte zugreifen: "Fehler beim Einloggen" ohne dass ich irgend eine Eingabe vorgenommen habe. Aktuell muss ich also die Pineingabe über die normale Tastatur vornehmen. Die entspricht aber nicht einmal ansatzweise meiner Vorstellung eines Klasse 3 Gerätes.

Wie können Sie diese Kombination anbieten ohne zu gewährleisten, dass die beiden Produkte zusammenarbeiten, wie sie es sollten? :?

Um einige Fragen vorweg zunehmen:
Win XP SP2 mit allen updates bis Jan. 2009
Die neusten und auch vorherige Treiber für den Kartenleser habe ich getestet. Ebenso wie die Version 3.1.0 von ALFBanCo.
Die HBCI-Karte ist von der 1822direkt und wurde beim Einrichten mit der entsprechenden Benutzerkennung versehen.
Don
 
Beiträge: 5
Registriert: Sa 31. Jan 2009, 12:01

Beitragvon dinelly » Sa 31. Jan 2009, 16:38

Hallo,

zunächst ist mir nicht verständlich, wieso du die "derzeitige Nutzung von Alf3" und der Kartenleser KAAN auswählen konntest.
Diesbezüglich habe ich vor Wochen bei ALF schon angemahnt, dass auf seiner Webseite die Auswahlmöglichkeit nur bis zur Version 2 besteht.

Nun gut, es wird dir auf anderer Weise gelungen sein.

Zu deinem Problem möchte ich dir folgende Erklärung geben:
1. die Auswahlmöglichkeit "Sichere PIN-Eingabe" hat nichts mit dem
Kartenleser zu tun. Es erfolgt hierbei eine "Verschlüsselung" deiner
Tastatureingabe. Quasi soll nicht mehr nachzuvollziehen sein, welche
Tasten benutzt wurden. Der Button ist meiner Meinung, irreführend.
2. da du "vorherige Treiber" erwähnst und ich jetzt auch nicht weiß, wie
du den Wechsel Vers.2 zu 3 gemacht hast, wird ALF in regedit immer
noch auf die "alten Schlüssel" zugreifen.

Es hilft wahrscheinlich nur:
- sichern der DB (HbDat001.dat) durch kopieren an einen Ort, den du dir
merken kannst.
- deinstallieren von ALF in Windows-Softwareverwaltung und der Treiber
für den oder die Kartenleser in Windows-Gerätemanager.
- Rechner danach herunterfahren.
- Rechner neu starten und den Kartenleser neu installieren
(Kontrolle des ok im Gerätemanager).
- ALF neu installieren; Kartenleser neu einrichten (alles automatisch
machen lassen); den gefundenen Treiber als Standard auswählen;
schließlich die DB wieder einbinden, wenn dich ALF danach fragt.
- eine Internetverbindung sollte bestehen.

Möglicherweise gibt es auch noch ein paar Klippen hinsichtlich des USB-Port. Das ist aber Windows-eigen und es empfiehlt sich, immer den gleichen Port zu verwenden.

Ich hoffe, nichts vergessen zu haben und dir gelingt nun alles.

Gut Holz!
Benutzeravatar
dinelly
 
Beiträge: 203
Registriert: Mo 23. Jul 2007, 19:21

Beitragvon Don » Sa 31. Jan 2009, 18:47

Hallo,

danke für die Tipps.
Besonders für den Hinweis mit der sicheren PIN-Eingabe ;)
Ich hatte angenommen, dass dies eine zusätzliche Aktivierung für die Tastatur des Lesers sein könnte nach dem die Einstellungen in den Optionen nichts bewirkten...

Zunächst einmal: Ich habe von Version 2 auf 3 upgedated. Das sollte deine Verwirrung etwas verringern. ;)
Ich habe die 3er Version am Anfang parallel zur 2er installiert. Allerdings ist die 2er Version als USB-Version im Einsatz, so dass ich davon ausgegangen bin, dass es keine registry-Probleme geben könnte.

Ich werde trotzdem nochmal alles runterwerfen...die Hoffnung stirbt ja bekanntlich zu letzt.
Don
 
Beiträge: 5
Registriert: Sa 31. Jan 2009, 12:01

Beitragvon Don » Sa 31. Jan 2009, 20:07

Hat leider auch nicht geholfen. Die Leser-Tastatur hat wieder nicht reagiert als die erste PIN-Abfrage kam. Im Gegenteil: Beim Einrichten des HBCI-Kontos hatte ich einen Zahlendreher bei der Karten-PIN - über meine Tastatur - eingegeben. Trotz klicken auf abbrechen wurde die Initialisierung noch 2 weitere Mal gesendet... Herzlichen Glückwunsch meine frisch bestellte Karte ist unbrauchbar.

Ich habe schon so manche Konten eingerichtet - nicht nur mit ALFBanCo allerdings dafür mit einem Leser von Reiner - und hatte bisher nie Probleme. Scheinbar ist die aktuelle Version doch nicht ein Schritt voraus in der Entwicklung dieser Software, die ich eigentlich immer ganz gerne verwendet hatte...
Don
 
Beiträge: 5
Registriert: Sa 31. Jan 2009, 12:01

Display Defekt

Beitragvon Glasfaser » Sa 31. Jan 2009, 20:56

Hallo ,

habe den Kartenleser selber die Tage mit Alfbanco 3 wie folgt eingerichtet :


1. Chipkartenleser Einrichtung wählen
2. CT/API Protokoll wählen und dann weiter drücken
3. CTAPIUtilities.dll wählen ..... mit Sicherer Pin-Eingabe ....und als Standard übernehmen

PS: Mein KAAN Trib@ank Kartenleser weißt ein defekt auf , so das im Display nur schwach zu erkennen ist , das man den Pin eingeben muß und auch andere Angaben darüber erscheinen sehr schwach .
Nach Rücksprache mit dem KAAN Support ,liegt eine Hardware Fehler vor, der bei den teilweise ausgelieferten Geräten mit der Firmwareversion V68.17 auftreten .
Komischerweise ohne PC Nutzung z.b. bei der Geldkartenabfrage ist alles lesbar !

Vielleicht liegt bei dir auch ein Display defekt vor ???!!!
Glasfaser
 
Beiträge: 8
Registriert: Mi 14. Jan 2009, 22:04
Wohnort: Ruhrgebiet

Beitragvon Don » Sa 31. Jan 2009, 21:14

Das Display zeigt mir gut lesbar "KAAN TriB@nk V68.17 Secoder 1" an.
Allerdings änderte sich das auch nicht als ich die Karte in Benutzung hatte :?:
Bei mir hatten beide Varianten (über das CT/API-Protokoll und PC/SC) keine Veränderung hervorgerufen. Allerdings glaube ich, dass ich nicht die CTAPIUtilities.dll ausgewählt hatte, sondern die CT32.dll. Würd es ja gerne testen aber mit ner gesperrten Karte... ;)

Offline reagiert die Tastatur am reader auch. Also wird es kein Problem mit der Tastatur selber sein.

Dann werd ich mir mal eine neue HBCI-Karte schicken lassen und es über die CTAPIUtilities.dll versuchen.
Don
 
Beiträge: 5
Registriert: Sa 31. Jan 2009, 12:01

Beitragvon dinelly » Sa 31. Jan 2009, 21:53

Das ist ein guter Hinweis von Glasfaser!

CT/API ist richtig. PC/SC ist doch die Schnittstelle der Computertastatur!

...aber, woher willst du wissen, daß die Karte unbrauchbar ist. Soweit ich mit meinen RDH oder DDV- Karten komme, kann ich die PIN immer auch nachträglich ändern.

Was sagt denn die Chipkartenverwaltung von Alf?
Kannst du deine Bank auch online ohne Alf, mit Karte und Kartenleser erreichen?
Benutzeravatar
dinelly
 
Beiträge: 203
Registriert: Mo 23. Jul 2007, 19:21

Beitragvon Christian211 » Sa 31. Jan 2009, 22:17

PC/SC ist doch die Schnittstelle der Computertastatur


Weniger

Bei der PC/SC-Schnittstelle handelt es sich um eine standardisierte Schnittstelle zur Unterstützung von Chipkartenterminals für Smartcards im PC-Umfeld. Die PC/SC-Schnittstelle wurde von der gleichnamigen Arbeitsgruppe entwickelt, die sich aus namhaften IT-Unternehmen zusammensetzte. Durch die flexible Gestaltung der PC/SC-Schnittstelle wird die Entwicklung von Smartcard-Anwendungen für verschiedene Betriebssysteme unterstützt.


Tastatur = PS/2 Personal System/2
Interface Bus = PCI Peripheral Component Interconnect


Soweit ich mit meinen RDH oder DDV- Karten komme, kann ich die PIN immer auch nachträglich ändern.

Üblicherweise wird nach 3 Falscheingaben der PIN die Karte gesperrt


Kannst du deine Bank auch online ohne Alf, mit Karte und Kartenleser erreichen?


Nicht wenn die Karte gesperrt wurde
Christian211
 
Beiträge: 409
Registriert: Sa 6. Jan 2007, 08:39
Wohnort: Berlin

Beitragvon dinelly » So 1. Feb 2009, 13:55

Danke Christian211,

selbstverständlich ist das richtig, was du schreibst. Wieder habe ich etwas dazu gelernt.
Die Falscheingabe von Don hatte ich auch schon gar nicht mehr berücksichtigt.

Schönen Sonntag!
Benutzeravatar
dinelly
 
Beiträge: 203
Registriert: Mo 23. Jul 2007, 19:21

Beitragvon ALF » Mo 2. Feb 2009, 10:41

Hallo,

wir haben mit Version 3.2.0 Verbesserungen für die Unterstützung des KAAN Trib@ank vorgenommen. Diese Version erscheint vorauss. noch diese Woche. Bei Bedarf können wir Ihnen gerne auch eine Beta-Version vorab zukommen lassen.

MfG
ALF
Benutzeravatar
ALF
Site Admin
 
Beiträge: 7622
Registriert: Do 9. Okt 2003, 14:21
Wohnort: Leingarten

Beitragvon Don » Di 17. Feb 2009, 19:34

Hallo,

der Versand der neuen HBCI-Karte hat ungewöhnlich lange gedauert.
Dadurch habe ich allerdings in der Zwischenzeit das Update auf Version 3.2.0 vornehmen können und jetzt lief alles absolut reibungslos.
Die Einrichtung klappte ohne Probleme, der Kartenleser wurde ohne Probleme erkannt und auch die PIN-Eingabe über die Tastatur des Lesers klappte ohne Probleme.

Zusammengefasst: Alles funktioniert so, wie man es sich vorstellt :)

Einziger Kritikpunkt:
Wieso wurde das Paket nicht gleich mit Version 3.2.0 vertrieben und somit die korrekte Zusammenarbeit des Programms mit dem Leser gewährleistet? Oder zumindest ein Hinweis hätte enthalten sein sollen, dass an einer aktuellen Version gearbeitet wird und man bei Bedarf eine Beta hätte bekommen können. Hätte mir einiges an Zeit, Nerven und auch 15€ gespart ;)
Don
 
Beiträge: 5
Registriert: Sa 31. Jan 2009, 12:01

Beitragvon ALF » Mi 18. Feb 2009, 08:32

Hallo,

freut uns, dass nun alles funktioniert hat.

Für die Probleme zuvor bitten wir um Entschuldigung.
Leider war der Kartenleser schneller verfügbar als unser Update.

MfG
ALF
Benutzeravatar
ALF
Site Admin
 
Beiträge: 7622
Registriert: Do 9. Okt 2003, 14:21
Wohnort: Leingarten

Bei mir geht es leider nicht

Beitragvon alf-rkj » Mi 6. Mai 2009, 08:59

Also ich habe jetzt den version 3.2.1 und habe auch 3.1.x gekauft mit karten leser kobil (KAAn tribank V68.17 Secoder 1) zusammen gekauft und installiert.. und egal was ich tue, ich kann den tastatur auf den gerät nicht verwenden.
Was mache ich falsch, und wie bekomme ich das ding zum laufen ?

Rudi
alf-rkj
 
Beiträge: 33
Registriert: Mi 6. Mai 2009, 08:48

Beitragvon ALF » Mi 6. Mai 2009, 09:38

Hallo,

Wählen Sie den Menüpunkt "Extras > Optionen > Pfade" und klicken Sie auf "Öffnen" bei "Allgemeine Einstellungen". Öffnen Sie die Datei "AlfBanCoAll.ini" und ändern Sie den Eintrag:
HasSecurePIN=0
nach
HasSecurePIN=1

Anschließend speichern Sie die Datei.

Überprüfen Sie auch, dass die Option "Extras > Optionen > PIN-Eingabe über Kartenleser-Tastatur, falls vorhanden" aktiviert ist.

Mfg

ALF AG
Benutzeravatar
ALF
Site Admin
 
Beiträge: 7622
Registriert: Do 9. Okt 2003, 14:21
Wohnort: Leingarten

Beitragvon alf-rkj » Mi 6. Mai 2009, 12:21

Das hat funktioniert.. Danke...

Aber warum muss das manuell gemacht werden ?? Und warum findet mann das nicht in der FAQ... ??

Grüße

Rudi
alf-rkj
 
Beiträge: 33
Registriert: Mi 6. Mai 2009, 08:48

Nächste

Zurück zu Chipkarten und Lesegeräte

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste